Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: problem with ineqdeco & remote access

From   <>
To   <>
Subject   RE: st: problem with ineqdeco & remote access
Date   Tue, 2 Oct 2012 21:42:03 +0100

Thanks to Nick Cox for his response.  You should do the checking he

I have another guess concerning your problem. A few months ago there was
a problem in Stata 12, inadvertently introduced, and some users reported
problems with the by() option to -ineqdeco- as a result of this problem.
The bug was quickly fixed by StataCorp in an update of 20jun2012, and
the problems with -ineqdeco- arise no longer. On this bug fix, see -help
     2.  egen, when the argument to fcn() was an expression of a
variable subtracted or multiplied
         by another variable, mistakenly unabbreviated the argument as
if it were a variable list.
         This has been fixed.
However, this is only a guess.  Whatever, I would check that the Stata
12 that you use is fully updated. (Type -update query-) The current
update level is 01 Oct 2012. 

Finally, see if you can reproduce your problem with a publicly available
Stata data set. E.g.

	sysuse auto
	ineqdeco price, by(foreign)

Professor Stephen P. Jenkins  <>
Department of Social Policy 
London School of Economics and Political Science
Houghton Street, London WC2A 2AE, U.K.
Tel. +44 (0)20 7955 6527
Changing Fortunes: Income Mobility and Poverty Dynamics in Britain, OUP
Survival Analysis using Stata:
Downloadable papers and software:

> -----Original Message-----
> From: Nick Cox []
> Sent: 02 October 2012 19:19
> To:
> Subject: Re: st: problem with ineqdeco & remote access
> -ineqdeco- was written by Stephen Jenkins, who is a member of this
> list. Before he chimes in, there are some things you can do.
> By the way, my guess is that the version of Stata being used, 9 or 12,
> is no consequence here. It's all about which version of -ineqdeco- you
> have.
> 1. If you look at the latest version on -ssc- you can see that the
> code has embedded comments, which start
> *! 2.0.2 SPJ May 2008 (fix bug arising if bygroup() and `touse' lead
> to no obs in a group)
> *!   bug fix method provided by Austin Nichols (many thanks!)
> I'll bet this is pertinent to your problem, i.e. you need 2.0.2 but
> have not got it.
> What you can do is type
> . which ineqdeco
> and see whether you get a report that starts as above, or -which-
> signals an earlier version.
> 2. Check thoroughly to see whether there are multiple versions of
> -ineqdeco- in different places on your system. For example, if you are
> on Windows, use the Command Prompt (or equivalent) to search for
> ineqdeco.ado on your drive with Stata.
> 3. Even if -ineqdeco- has been updated successfully from SSC, there is
> evidently still a problem, so 2. above should be reported in
> conjunction with the results of typing -adopath-. It could be that you
> are seeing an old version of -ineqdeco-, which trumps a newer version
> becase of your -adopath-.
> 4. As you brush your teeth, each time say "Stata, not STATA".
> (Question is well stated otherwise!)
> Nick
> On Tue, Oct 2, 2012 at 6:44 PM, simone scarpa
> wrote:
> > I am a beginner with STATA and I apologize in advance if my question
> > is long and/or too simple.
> >
> > I have a problem with the ineqdeco module. I have used this
> > module before but today I have encountered a strange problem with
> > bygroup option.
> > When I run the following command:
> > . ineqdeco income, bygroup (ethnicgroup)
> > I get only the first part of the output (Percentile ratios,
> > Generalized Entropy indices, Atkinson indices) but then, after the
> > three tables, I do not get the decomposition of the indices but,
> > instead, I get the following error message:
> > . invalid syntax
> > . r(198);
> >
> > I think that this problem is strange for two reasons:
> > (1) Firstly, the syntax worked perfectly - with the same dataset -
> > until a few months ago (May 2012). For privacy reasons, I need to
> > access the computer hosting my dataset through remote access. This
> > computer is in fact administered by a governmental body. I don't
> > which changes may have been done to the Stata software installed on
> > that computer since May 2012 (when the syntax still worked). I
> > asked to the computer administrators to reinstall the module with
> > following command:
> > . ssc inst ineqdeco, replace
> > However this did not solve my problem, i.e. I still get the same
> > message (invalid syntax + r(198)).
> > (2) Secondly, the same syntax works perfectly on my computer, with
> > another dataset. I have Stata 9 on my computer while Stata 12 is
> > instead installed on the remote computer.
> >
> > If the problem is related to the Stata software installed on the
> > remote computer, I need to be able to explain to the computer
> > administrators what they have to do in order to solve this problem
> > it can be solved).
> >
> > I do hope that someone in this mailing list can help me.

Please access the attached hyperlink for an important electronic communications disclaimer:

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index