Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: problem with ineqdeco & remote access

From   Nick Cox <>
Subject   Re: st: problem with ineqdeco & remote access
Date   Tue, 2 Oct 2012 19:19:23 +0100

-ineqdeco- was written by Stephen Jenkins, who is a member of this
list. Before he chimes in, there are some things you can do.

By the way, my guess is that the version of Stata being used, 9 or 12,
is no consequence here. It's all about which version of -ineqdeco- you

1. If you look at the latest version on -ssc- you can see that the
code has embedded comments, which start

*! 2.0.2 SPJ May 2008 (fix bug arising if bygroup() and `touse' lead
to no obs in a group)
*!   bug fix method provided by Austin Nichols (many thanks!)

I'll bet this is pertinent to your problem, i.e. you need 2.0.2 but
have not got it.

What you can do is type

. which ineqdeco

and see whether you get a report that starts as above, or -which-
signals an earlier version.

2. Check thoroughly to see whether there are multiple versions of
-ineqdeco- in different places on your system. For example, if you are
on Windows, use the Command Prompt (or equivalent) to search for
ineqdeco.ado on your drive with Stata.

3. Even if -ineqdeco- has been updated successfully from SSC, there is
evidently still a problem, so 2. above should be reported in
conjunction with the results of typing -adopath-. It could be that you
are seeing an old version of -ineqdeco-, which trumps a newer version
becase of your -adopath-.

4. As you brush your teeth, each time say "Stata, not STATA".
(Question is well stated otherwise!)


On Tue, Oct 2, 2012 at 6:44 PM, simone scarpa <> wrote:

> I am a beginner with STATA and I apologize in advance if my question
> is long and/or too simple.
> I have a problem with the ineqdeco module. I have used this excellent
> module before but today I have encountered a strange problem with the
> bygroup option.
> When I run the following command:
> . ineqdeco income, bygroup (ethnicgroup)
> I get only the first part of the output (Percentile ratios,
> Generalized Entropy indices, Atkinson indices) but then, after the
> three tables, I do not get the decomposition of the indices but,
> instead, I get the following error message:
> . invalid syntax
> . r(198);
> I think that this problem is strange for two reasons:
> (1) Firstly, the syntax worked perfectly - with the same dataset -
> until a few months ago (May 2012). For privacy reasons, I need to
> access the computer hosting my dataset through remote access. This
> computer is in fact administered by a governmental body. I don't know
> which changes may have been done to the Stata software installed on
> that computer since May 2012 (when the syntax still worked). I already
> asked to the computer administrators to reinstall the module with the
> following command:
> . ssc inst ineqdeco, replace
> However this did not solve my problem, i.e. I still get the same error
> message (invalid syntax + r(198)).
> (2) Secondly, the same syntax works perfectly on my computer, with
> another dataset. I have Stata 9 on my computer while Stata 12 is
> instead installed on the remote computer.
> If the problem is related to the Stata software installed on the
> remote computer, I need to be able to explain to the computer
> administrators what they have to do in order to solve this problem (if
> it can be solved).
> I do hope that someone in this mailing list can help me.
*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index