[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: lcolor not allowed

From   Michael Hanson <[email protected]>
To   [email protected]
Subject   Re: st: lcolor not allowed
Date   Wed, 15 Aug 2007 15:04:09 -0400

On Aug 15, 2007, at 12:12 PM, Davide Cantoni wrote:

Thank you, Sergiy, for your suggestion. Alas, here's the result:

. clear

. sysuse auto
(1978 Automobile Data)

. twoway line l w, lc(red)
option lc() not allowed
Those two lines execute without error with Stata 9.2 on two Macs I tried (one with OS X 10.4.10 and one other with 10.4.9), so the problem is specific to your particular machine. What type of Mac do you have, and which OS version? Are you using a language other than U.S. English?

To echo Sergiy's questions: When did you start noticing this problem? When was the last time that graph options worked in this Stata installation? What modifications have you made to your Mac since then?

Given that your reported problem persists, I would recommend the following steps -- from least to most intensive/invasive/disruptive -- to try to sort our your problem:

1. Check that your Mac installation is up-to-date by typing -update query-. You suggest you have already done this step, but it would be helpful to confirm that you get the same results as below (for Stata 9.2), particularly with regard to the dates:

. update query

Stata executable
folder: /Applications/Stata/
name of file: StataSE
currently installed: 20 Jul 2007
latest available: 20 Jul 2007

Ado-file updates
folder: /Applications/Stata/ado/updates/
names of files: (various)
currently installed: 20 Jul 2007
latest available: 20 Jul 2007

Do nothing; all files up to date.

2. Confirm that you have the most recent versions of "twoway.ado" and "graph.ado" on your Mac. Confirm the following commands in Stata:

. which twoway
*! version 1.1.1 23jan2004

. which graph
*! version 1.1.6 08jan2005

If these version numbers and dates are different but the locations are the same, you should reinstall Stata from the original media -- something is likely corrupted. (But see #7 below first.) If the locations are also different, then check your -adopath-: it may be that some other programs are being called instead of the standard graphics ones. If so, fix the path.

3. Quit and relaunch Stata. If you have a "" file, move it aside (or rename it) before relaunching Stata.

4. Log out, log back in, and relaunch Stata. Do not run another other programs before testing for your error in Stata.

5. Create a new user account, and try running Stata from it. In particular, if the simple graphing example given by Sergiy runs in the new user account, then something is wrong with your current account: perhaps your Stata preferences are corrupted. In that case, you need to figure out what is the problem with your current account. That, however, is not a Statalist question. If you still have a problem....

6. "Safe boot" your Mac and then try Stata. Restart your Mac, holding down the "Shift" key until you see the login window with the words "Safe Boot" shown. (Note: depending on your Mac, this could take a full minute or two to complete -- don't let up on the shift key!) If this solves your problem, you may be running some sort of input manager, kernel extension, "haxie", etc. that is interfering with your use of Stata in some novel fashion. I really doubt this is the issue (and frankly, I'm not certain Stata will run on a safe- booted Mac -- although I suspect it should), but if you've gotten this far....

7. If none of these steps fix your problem, you should probably check your Mac for hard disk corruption, and fix it BEFORE you re-install Stata. Boot your Mac from the System Installation CD or DVD that shipped with it. Once you get to the main window of the Installer, select "Disk Utility" from the "Utilities" menu. (Note: I am recalling these commands from memory, so they may not be exactly correct.) Fix any directory damage that might be indicated, then restart your Mac. Install all the latest system-related Software Updates, reboot, then reinstall Stata from the original media.

8. If all that still doesn't fix your problem, you almost certainly need to talk with Stata Corp's technical support staff. If you've noticed any other programs acting strangely, you may need to re- install the OS. Definitely not a question for either Statalist or Stata Corp's technical support, however.

Hope this helps. Once you find the cause of your problem, please report it back to Statalist for future reference.

-- Mike

* For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index