Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: invalid syntax error in reclink depending on variables for fuzzy matching

From   Roth Florian <[email protected]>
To   "[email protected]" <[email protected]>
Subject   st: invalid syntax error in reclink depending on variables for fuzzy matching
Date   Thu, 3 Apr 2014 15:40:22 +0000

Dear all,

I'm trying to run a fuzzy match of car registry data with additional price data. Since the registry data is not very clean I can't just use merge. When I use the following code I get an error invalid syntax r(198). I usually get the error after about half the matching is done. I ran the code using Stata 12.1 and reclink 1.7

use CarReg.dta, clear

reclink str_brand str_model_part1 str_model_part2 rom_displacement rom_fuel_type rom_gear_box rom_import_year using "Price.dta", idmaster(idmaster) idusing(idusing) gen(matchscore) ///
			required(str_brand str_model_part1 rom_displacement rom_import_year rom_fuel_type rom_gear_box) wmatch( 1 1 3 1 1 1 3)

I get the following output:

15429 perfect matches found

Going through 48915 observation to assess fuzzy matches, each .=5% complete
.........invalid syntax

The variables starting with "str_" are strings, those starting with "rom_" are integer variables converted to roman numbers (I found that the matching works better with roman numbers). I can't really find a syntax error and the same code has worked with a slightly different data set and without the variables rom_fuel_type rom_gear_box. I have started removing variables to see if they could be the problem. If I remove enough variables the code works. But I can't figure out what is wrong with these variables. Does somebody have an idea what the problem could be?

Best regards,
Florian Roth

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index