Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Re: Mean2 question

From   Nick Cox <[email protected]>
To   [email protected]
Subject   Re: st: Re: Mean2 question
Date   Tue, 27 Sep 2011 09:12:04 +0100

This doesn't make complete sense without the original question from 14
September, copied below my signature.

The key points I can establish are

1. Kate is using -mean2- (Roy Wada, SSC) which in turn calls -outreg2-
(Roy Wada, SSC) and -sxpose- (mine, SSC). In turn they call yet other
user-written commands by Roy and official commands.

2. Like Richard, I can replicate this example without difficulty.

3. The objection is to some -linesize()- call somewhere in these
programs and what they call.

There are further possibilities:

(a) A mystery element here is a difference between computers, neither
of which is specified. Kate might specify which flavour of Stata and
which operating system are involved in each case, just so we can think
about what that might imply.

(b) -set trace on- should in principle show where the problem is being
generated, although Kate should be prepared to look in a log thousands
of lines long to work out what is being called by what, possibly at
several levels. Since the example worked for me, I can't tell where it
fails for her, but I looked at a log some 74,000 lines long from -set
tracedepth 5- and could identify calls deep inside Stata's own code
when I run this example to an official command -_prefix_footnote- with
-linesize(62)- but it is not at all clear whether that would be the
same on Kate's computer, or why that might be problematic in Kate's

Either way, this is an official command called indirectly by Roy's code.


Kate V 14 Sept

I am receiving an error message when running mean2 as in the example
from the mean2 help:

use, clear
mean2 height age weight smsa using myfile.txt, over(sex) cat(Male
Female) excel replace
option linesize() not allowed

When I use the exact same code on another computer I do not receive
this error message.

I haven't been able to find anything about this in the help file or on
statalist.  Can anyone explain what might cause this error and what I
would need to adjust on my computer to prevent it?

On Tue, Sep 27, 2011 at 3:49 AM, Kate Vyborny <[email protected]> wrote:
> Thank you very much for this suggestion, Dr. Williams.
> I have run update all, update swap and the install / replace options
> for all three of the components (mean2, sxpose, outreg2) without
> success.  I still receive the same error message.
> Any other suggestions would be welcome!
> Thank you!
> Kate
> From  Richard Williams <[email protected]>To
> [email protected][email protected]
> Re: st: Mean2 questionDate  Wed, 14 Sep 2011 19:13:22 -0400
> First, note that the help file for -mean2- (available from SSC) says
> "You will also need to install the latest versions of outreg2 and
> sxpose from ssc." So, make sure that both machines have both programs,
> and also that your Stata is fully updated.
> Second, messages like this often seem to come about when there is some
> kind of installation problem or you don't have the most current
> version of programs. So, if problems persist, you might try
> ssc install mean2, replace
> ssc install sxpose, replace
> ssc install outreg2, replace
> update all
> Incidentally, your example worked fine for me, once I realized that I
> needed sxpose too.

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index