[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: AW: xtserial and xtcsd do not run

From   "Martin Weiss" <>
To   <>
Subject   RE: st: AW: xtserial and xtcsd do not run
Date   Wed, 16 Sep 2009 19:48:35 +0200


"-xtserial- is part of official Stata."

I cannot find it in my installation, but got it from -ssc-. It is certainly
not mentioned in my manuals, either...


-----Original Message-----
[] On Behalf Of Nick Cox
Sent: Mittwoch, 16. September 2009 19:43
Subject: RE: st: AW: xtserial and xtcsd do not run

-xtserial- is part of official Stata. Thus there is no question of
either installing or uninstalling it as an extra. Your problem with
-xtserial- arose because Stata was not properly updated previously. 

-xtcsd- in contrast is a user-written program from SJ and SSC. 

(Please remember to spell out where user-written programs you refer to
come from, as requested in the FAQ.) 

It seems that you have problematic input for your calls to -xtcsd-. I
imagine that the authors of this program, who may not be members of
Statalist, would want to know much more about your data than you say


thank you for your fast and helpful response. I updated Stata and now  
xtserial works.
With xtcsd I don't get the previuos error message anymore. However, if  
I try xtreg, fe and then want to conduct xtcsd (method of Pesaran) it  
. xtcsd, pesaran
Unknown function *sqrt()

or if I take Friedman/Frees it says:
. xtcsd, friedman
no observations

Do you have any ideas what may be the cause for these errors?

Zitat von Martin Weiss <>:

> What does -which xtserial- give you? Have you -update-d your official
> fully?

> I'm doing some analysis with panel data. For this reason, today I
> installed via ssc the functions xtserial, xtcsd, xttest0-3 and
> pantest2. Interestingly, the xtserial and xtcsd functions do not run.
> The xttest and the pantest2 functions, however, work without any
> problems. With xtserial I tried for example the following (after
> declaring the data to be time series using "tsset bankid counter"):
> -xtserial ln_medbas relfva relloans
> But I received the following error message:
>     _TS_p_delta_getnumb():  3499  strtoreal() not found
>   _TS_p_delta_increment():     -  function returned error
>             _TS_p_delta():     -  function returned error
>                   <istmt>:     -  function returned error
> The same came when I tried xtcsd.
> I tried to install xtserial again, but Stata said it is already
> installed. Then I tried to uninstall it, but it said it cannot find
> the package...

*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2020 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index