[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

RE: st: Problem Using Bootstrapping with Ordered Logit 'gweight not allowed'

From   "Rodwan M Abouharb" <>
To   <>
Subject   RE: st: Problem Using Bootstrapping with Ordered Logit 'gweight not allowed'
Date   Tue, 20 May 2008 00:32:05 -0500

Hi Jeff

Thank you very much for your help that fixed the issue. 

One final question. When trying to run the equation below STATA won't let me cluster by country 'cluster (ccode)' when bootstrapping. I have checked the integrity of the data-set and there are no repeated values. Is there some way to cluster by country?

Thank you


ologit tort imfnumberyearsunder8104 gdppcipol democ logpopi interstate internal UKcol IMFindirecteffect4th tortlag1 if highincomeoecd==0 & postcommunistindep93==0 & indep83899404==0, cluster (ccode) vce(boot)
(running ologit on estimation sample)

Bootstrap replications (50)
----+--- 1 ---+--- 2 ---+--- 3 ---+--- 4 ---+--- 5 
repeated time values within panel
the most likely cause for this error is misspecifying the cluster(), idcluster(), or group() option

M. Rodwan Abouharb 
Assistant Professor 
Department of Political Science
219 Stubbs Hall
Louisiana State University 
Baton Rouge, Louisiana 70803
Tel: 225-578-3881
Fax: 225-578-2540

-----Original Message-----
From: [] On Behalf Of Jeff Pitblado, StataCorp LP
Sent: Monday, May 19, 2008 5:39 PM
Subject: Re: st: Problem Using Bootstrapping with Ordered Logit 'gweight not allowed'

Rodwan M Abouharb <> is having trouble with the -vce(bootstrap)-
option with -ologit-:

> I am a newbie when it comes to bootstrapping. The vce command seemed like
> the easiest way to obtain alternative error estimates for each of the
> independent variables. I am using STATA 9.2.
> I have been trying to implement the bootstrapping option using an ordered
> logit. I have tried variations on this including removing all of the 'if'
> and 'cluster' statements and tried also using vce(jack). None of these seem
> to work and I always get the 'option gweight not allowed' error term. I
> can't find any information on what 'gweight' refers too.

Rodwan should type the following within Stata to check on the current state of
the Stata 9.2 executable and ado-files.

	. update query

Based on Rodwan's reported error message, it appears that Rodwan's Stata 9.2
executable is not fully up-to-date.  The remedy for this is to run the
following Stata commands:

	. update all
	. update swap


For those interested, the update on 31july2006 contained the addition of the
-gweight- option to the -_parse- command.  -_parse- is used by the parsing
engine employed by the -bootstrap- and -jackknife- prefix commands, which are
called when the -vce(bootstrap)- and -vce(jackknife)- options are specified.

*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2022 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index