[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]
st: Naming convention, Ideas?
I am looking into writing a suite of wrapper data management commands around merge, mmerge, append, joinby, and cross that can either take a stata data file, gzip compressed data file or simply a comma or tab delimited text file as the -using- argument, e.g. <cmd_name> using *.dta | *.dta.gz | *.dgz | *.txt | *.cvs [, * ].
1) Any ideas w/ regard to a consistent naming convention that could be used? as I'd like to get it right the first time. I am not very fond of using an integer as a suffix a la cf2, cf3 for various reasons (e.g not very informative, unclear if integers imply incremental functionality, can conflict with others' names). So far I thought of:
- mmergeplus, appendplus, joinbyplus (but rather long)
- aappend, jjoinby, (but look like typos, besides mmerge already exists)
2) Would anyone find these useful, i.e. should they be posted on SSC?
* For searches and help try: