Statalist The Stata Listserver

[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Naming convention, Ideas?

From   n j cox <>
Subject   Re: st: Naming convention, Ideas?
Date   Wed, 22 Mar 2006 15:35:17 +0000

My suggestion is none of these. Find a suitable
name, say -pjcombine-, and then write a command
with subcommands, so that your syntax is

pjcombine append <whatever>
pjcombine merge <whatever>


0. There are many precedents in Stata itself.

1. One program is easier to keep track of than several.

2. -combine- is a good word, but StataCorp lay claim
to all the words in the English language. Some of us
have forgotten that in the past -- "accidentally on
purpose", perhaps -- and you might choose to forget that too.
At worst, StataCorp may grab "your" program name and either
your program has been superseded, or you need to change
the name.

3. -pj- would be both modest and good PR.

Put them on SSC!

P.S. on integers: there are two conventions in use. Typically
low integers (esp. 2, 3) mean versions of the command; high
integers (esp. 5, 6, 7, 8) mean versions of Stata it works
with. In practice that is less confusing than it seems, as
although many programs go through much revision, programmers
don't change names that often.

If <program><n> means "works with Stata <n>", then I suggest
that should always be explicit in its help.



I am looking into writing a suite of wrapper data management commands around merge, mmerge, append, joinby, and cross that can either take a stata data file, gzip compressed data file or simply a comma or tab delimited text file as the -using- argument, e.g. <cmd_name> using *.dta | *.dta.gz | *.dgz | *.txt | *.cvs [, * ].

Two questions:
1) Any ideas w/ regard to a consistent naming convention that could be used? as I'd like to get it right the first time. I am not very fond of using an integer as a suffix a la cf2, cf3 for various reasons (e.g not very informative, unclear if integers imply incremental functionality, can conflict with others' names). So far I thought of:

- mmergeplus, appendplus, joinbyplus (but rather long)
- aappend, jjoinby, (but look like typos, besides mmerge already exists)

2) Would anyone find these useful, i.e. should they be posted on SSC?

* For searches and help try:

© Copyright 1996–2021 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index