Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: xtabond deletes some variables

From   "Thuy Le" <[email protected]>
To   <[email protected]>
Subject   st: xtabond deletes some variables
Date   Mon, 2 Aug 2004 22:21:38 -0400

Hi all,

Does anyone experience the problems with .xtabond command that deletes some
variables after the estimation?

This is my command:
	. xtabond goldcap inflation gdpcapgro real loggdpcap95 sdevgdp
sdevinflation loggoldlcu credgdp stkpen, lags(1) artests(2)

The results come out OK, but when I run .outreg
	. outreg using august2a.out

STATA gives the following error:
	"variable goldcap not found"

When I rerun the .xtabond command above, STATA produces the same error
	"variable goldcap not found"

When I check the variables window, the variable named "goldcap" is not

(The version of STATA is 8.2)

Thank you for your help,

Thuy Le

-----Original Message-----
From: [email protected]
[mailto:[email protected]]On Behalf Of Nick Cox
Sent: Monday, August 02, 2004 1:24 PM
To: [email protected]
Subject: st: RE: tostring question

This depends on what you are looking for and what the data
are like. Note that the display format of the numeric
variable you are trying to convert is
irrelevant unless you use the -usedisplayformat-

The most relevant part of the help is probably

-force- specifies that conversions entailing loss
of information may be forced.  Loss of
information means one of two circumstances:  (1) The result of
"format")) is not equal to varname, i.e. the conversion is not reversible
loss of information.  (2) replace was specified but a variable has
associated value
labels.  In circumstance (1), it is usually best to specify usedisplayformat
format().  In circumstance (2), value labels will be ignored in a forced
conversion.  Note also decode as the standard way to generate a string
based on value labels.

[email protected]

> -----Original Message-----
> From: [email protected]
> [mailto:[email protected]]On Behalf Of
> R.E. De Hoyos
> Sent: 02 August 2004 18:15
> To: [email protected]
> Subject: st: tostring question
> I am trying to transform a numeric variable (double %10.0g)
> into string
> using -tostring-, however I get the following outcome:
>  tostring folio, gen(sfolio)
> folio cannot be converted reversibly; no generate
> When I try the same command with a similar variable (long
> %12.0g) -tostring-
> works fine.
> Is there a way to get the string variable I am looking for?
> Thanks,
> Rafa
> *
> *   For searches and help try:
> *
> *
> *

*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index