Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: Stata for Linux (Ubuntu 11.10)

From   Ulrich Kohler <[email protected]>
To   [email protected]
Subject   st: Stata for Linux (Ubuntu 11.10)
Date   Thu, 08 Mar 2012 22:59:16 +0100

Dear Stata-for-Linux Users,

I just installed Stata 12 on my new computer with Linux Ubuntu 11.10. After installation I was able to run the console version but when I entered

$ ./xstata-mp

I got the an error saying that the library "libgtksourceview1.0-0" was missing. The reason for that error is that Ubuntu 11.10 has a newer version of that library. I tried to just use the newer library instead of the older but that didn't work. I also tried to install libgtksourceview1.0-0, but the library was not part of the standard repositories. After some googling I came up with a solution that I want to share with you. So here is what I did to install that library:

I opened the file /etc/apt/sources.list as root:

$ gksu gedit /etc/apt/sources.list &

I added the line

deb natty main universe

at the end of sources.list and saved the file. (You may want to use a different mirror of the ubuntu archives if you life outside Europe). In the terminal I updated the package list using

$ sudo apt-get update

This took a while. After the process was finished I was able to install libgtksurceview1 with Synaptic. I haven't checked but

$ sudo apt-get install libgtksurceview1

should also work.

After installation I removed the line "deb natty main universe" from sources.list and typed

$ sudo apt-get update


Kind regards

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index