Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: merge error

From   Nick Cox <>
To   "''" <>
Subject   RE: st: merge error
Date   Mon, 29 Nov 2010 11:40:18 +0000


-merge- in Stata 11 still supports the old syntax, but when you try to use the new syntax your problem is, so far as I can guess, evidently that your Stata is (still) not properly -update-d. -merge- needs to use various Mata programs that it cannot see on your Stata. 

Type -update query-. 

If that doesn't work, see Maarten Buis' advice to contact Stata tech support. 


Nirina F

Thank you for your response.
I updated and tried the merge again but got the same error message afterward.

Then I tried again
merge  vid using "C:\Documents and Settings\Desktop\hsp"
please not it is without m:1 whichstata 11 requires and then it worked.
however before the update I tried merge without the m:1 but it said
you have to use the new merge command.
my question now: is merge  randomly working?

On Mon, Nov 29, 2010 at 9:46 AM, Mitch Abdon <> wrote:

> Check this thread:
> On Mon, Nov 29, 2010 at 2:37 PM, Nirina F <> wrote:

>> Hello, I am trying to merge and I could not with the following error.
>> Can anyone let me know what is going on please?
>> Thank you
>>  merge m:1 vid using "C:\Documents and Settings\Desktop\hsp"
>> (pathsplit() in lmatabase, compiled by Stata 11.1, is too new to be
>> run by this version of Stata and so was ignored)
>>          fullfilename():  3499  pathsplit() not found
>>                 <istmt>:     -  function returned error
>> r(3499);

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index