Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

RE: st: Questions about -rspread-

From   "louis boakye-yiadom" <[email protected]>
To   [email protected]
Subject   RE: st: Questions about -rspread-
Date   Thu, 19 May 2005 17:37:13 +0000

Many thanks.


From: "Nick Cox" <[email protected]>

As already explained, the "Files" message
is probably a side-effect of the way that
-rspread- uses various files. It is not smart
enough to handle filenames with
embedded spaces that are allowed by your
operating system.

Nor could it be: -rspread- predates
the change in operating system rules that
creates this problem. This problem is likely
to be capricious insofar
as it may depend on one or more of

1. which directory you are working in

2. where your datafiles are stored

3. where a -tempfile- command will create
a temporary file

none of which I can deduce at this distance.

I am not absolutely sure precisely where
the fault lies, but that is immaterial,
as examination of -rspread- makes it evident
that the program can and should be rewritten
without any file handling whatsoever.

The third message is a consequence of the
fact that -rspread- creates various variables
and then tries to -drop- them before it
finishes. If it falls over before it does that,
that the variables will be left behind, which
creates a problem on subsequent runs.

I cannot explain your second report.

As strongly hinted yesterday, at present you are
better off with -glcurve-. There is little point
in your persisting with -rspread- in its
present state.

I cannot say when -rspread- will be re-released.

[email protected]

louis boakye-yiadom

> Richard, thanks for the reply. Actually, I have tried giving
> the -rspread-
> command again several times after reading your reply and the
> results are
> puzzling. I had the following for the first three attempts:
> 1st attempt: there was what looked like a correct output, but
> with the error
> message:
> invalid 'Files'
> r(198);
> 2nd attempt: worked fine
> 3rd attempt:
> mdmean already defined
> r(110);

*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index