Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Some experiences with Stata 10 for Linux


From   "Lord Yupa" <lrdyupa@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Some experiences with Stata 10 for Linux
Date   Thu, 5 Jul 2007 11:36:27 +0200

2007/7/4, Alan Riley <ariley@stata.com>:
> - After installation console Stata works, but xstata didn't start due to
> a missing libary, namely "libtiff.so.3". ...

Ulrich then went on to describe some truly heroic machinations that he
performed to install new operating system libraries.  After which, his
installation worked.

While I admire Uli's resourcefulness and tenacity, I would not
recommend that others follow his approach.  Instead, simply install the
statically-linked version of Stata from the CD r
I tried both the softlinking (/usr/lib/libtiff.so.3 ->
/usr/lib/libtiff.so.4) and the installation of the statically-linked
version of stata from CD and both apparently worked for me. The link
solution was proposed in other forums for other software with the same
problem due to the migration of most distributions from libtiff3 to
libtiff4. Perhaps, for other "heroic" linux user, it could be useful
to know what version of libtiff was used in order to create
precompiled packages of compatibility libraries.


> (a): Stata used a non-monospaced font for results and help files,
> although the font mentioned in the preferences menue was "fixed 10".
> However, when I clicked on the font, the highlighted font in the list
> was "sans 10".

We have not heard of this from any other users nor can we reproduce
it on any of our own Linux systems.  It is possible that the default
font Stata tried to use was not available on his system, and so the
system defaulted to what it thought was the closest match.  Ulrich
should contact Stata Technical support at tech-support@stata.com
so that they can help diagnose what is unique about his system.
As a workaround, Ulrich should be able to change the font in
his Preferences to one of his liking.
I have the same problem with default font (tested on debian testing
and ubuntu feisty fawn) and I changed the font in preference. (Perhaps
a missing font in debian-based distributions?).
What is the default intended font corresponding to "fixed 10"?

I don't think these as "bugs" of the package, but only as "mild
annoyances". I don't even think about writing to stata technical
support because the workarounds take as less as 5 minutes to resolve
both. I hope that this thread could be of some interest for other
linux users.
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index