Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Some experiences with Stata 10 for Linux


From   Ulrich Kohler <kohler@wzb.eu>
To   statalist@hsphsun2.harvard.edu
Subject   st: Some experiences with Stata 10 for Linux
Date   Wed, 04 Jul 2007 17:07:50 +0200

I have now installed Stata 10 for Linux on 2 (3?) different Linux
systems. Just thought to share some of my experiences:

(1) Stata 10 on Xubuntu, "Dapper Drake"

- It was not possible to install from CD, but following the advice from
[GSU] A.3 "troubleshooting tips" works nicely. 

- After installation console Stata works, but xstata didn't start due to
a missing libary, namely "libtiff.so.3". I issued

$ locate libtiff.so

in a Linux terminal, which showed me "libtiff.so.4" was available in
"/usr/lib", but not "libtiff.so.3". I decided to create a soft pointing
to libtiff.so.4:

# cd /usr/local
# ln -s libtiff.so.4 libtiff.so.3

A second try to fire up xstata resulted in another missing library. I
forgot its name, but I was able to install the library with apt-get.
Afterwards xstata worked nicely.

(2) Stata 10 on Suse 9.something

This was a big mess. It already started with the problem that I could
not see the install script on the mounted Stata CD. I only saw some
files that seem to be for Macintosh. After copying the materials over
the network from a nearby Windows computer I was able to install Stata
and run Stata for the console. Lot's of libraries were missing for
xstata, however. Installation of the libraries required lots of further
things. I finally gave up and decided to upgrade my system to Ubuntu-
7.04 "Feisty Fawn" (I wanted to do that anyway).

(3) Stata 10 on Ubuntu 7.04 "Feisty Fawn". 

Installation worked identical as Xubuntu "Dapper Drake" (see point 1
above). However it was not necessary to install the further library with
apt-get. 


(4) Finally, there are two issues with Xstata on the two systems:

(a): Stata used a non-monospaced font for results and help files,
although the font mentioned in the preferences menue was "fixed 10".
However, when I clicked on the font, the highlighted font in the list
was "sans 10". 

(b): 

. sysuse auto
. reg weight
. reg
95,0 found where number expected
r(198);

. logit foreign
. logit
95,0 found where number expected
r(198);


Is this a bug? I noticed that the syntax diagram of -regess- is 
-regress depvar [indepvars]-, which somhow implies that -regress-
without varname is no longer valid syntax. However, the help-file also
mentioned

. reg, beta

which results in the same error message.


Many regards
Uli










*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index