Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at statalist.org.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: Autocorrelation after xtdpdsys


From   Angela C <aggela.christou@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   st: Autocorrelation after xtdpdsys
Date   Fri, 1 Feb 2013 03:20:27 +0200

I am using xtdpdsys to estimate a panel with N=27 and T=17.

the results come out as follows

xtdpdsys Deb Gr INT, lags(1) vce(robust) artests(2)

System dynamic panel-data estimation         Number of obs         =       430
Group variable: CTY                          Number of groups      =        27
Time variable: Year
                                             Obs per group:    min =        14
                                                               avg =  15.92593
                                                               max =        16

Number of instruments =    138               Wald chi2(3)          =    677.64
                                             Prob > chi2           =    0.0000
One-step results
------------------------------------------------------------------------------
             |               Robust
   Deb |      Coef.   Std. Err.      z    P>|z|     [95% Conf. Interval]
-------------+----------------------------------------------------------------
   Deb |
         L1. |   1.091666   .0627754    17.39   0.000     .9686287    1.214704
             |
      Gr |  -104.3667   16.53084    -6.31   0.000    -136.7665   -71.96683
         INT |   -1.38898   .4177452    -3.32   0.001    -2.207746   -.5702147
       _cons |   2.437429   2.130174     1.14   0.253    -1.737636    6.612494
------------------------------------------------------------------------------
Instruments for differenced equation
        GMM-type: L(2/.).Deb
        Standard: D.Gr D.INT
Instruments for level equation
        GMM-type: LD.Deb
        Standard: _cons



I then run the Arellano-Bond postestimation test and stata returns:

Arellano-Bond test for zero autocorrelation in first-differenced errors
  +-----------------------+
  |Order |  z     Prob > z|
  |------+----------------|
  |   1  |-3.4443  0.0006 |
  |   2  |-.37263  0.7094 |
  +-----------------------+
   H0: no autocorrelation

According to my model, the 2nd order autocorrelation appearing in the
test has been corrected by the programme (I set artests(2))?

If it was not corrected, is there a way to correct it afterwards and
take new, corrected coefficients?

Thank you.
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/faqs/resources/statalist-faq/
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index