Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: r(3900) when doing xtabond2

From   Muhammad Anees <>
Subject   Re: st: r(3900) when doing xtabond2
Date   Fri, 18 May 2012 18:14:51 +0500


This topic appeared many times and there are many possibilities what
you got that warning. Please look it some search results on Statalist
and also one here:

which appeared in 2010. I think it can give you a bit of hint to
figure out the reasons.


On Fri, May 18, 2012 at 6:03 PM,  <> wrote:
> Dear statalist users,
> I started using Stata only about one week ago, so I am not really an expert,
> but I try to be as specific about my problem as possible:
> I have a panel with 21 countries and 8 years, including 7 variables plus
> time and cross section dummies. The panel is almost perfectly balanced, only
> few observations are missing. I am using a Stata version with 32bit on a
> laptop with 64 bit Windows and at a PC with 32 bit Windows.
> First, I tried to re-estimate the output that I produced with Eviews (mainly
> panel estimations with cross section and/or period fixed effects). This
> worked quite will, I managed to get exactly the same output as I did in
> Eviews. But when I try to estimate the same model with xtabond2 I am facing
> huge problems. Usually, I get the following error message:
> . xtabond2 LHS-variable all RHS-variables year*, gmm(list of endogenous RHS
> variables) iv(year*)
> Favoring space over speed. To switch, type or click on mata: mata set
> matafavor speed, perm.                      J():  3900  unable to allocate
> real <tmp>[268485,76710]
>              _Explode():     -  function returned error
>           _ParseInsts():     -  function returned error
>         xtabond2_mata():     -  function returned error
>                 <istmt>:     -  function returned error
> r(3900);
> Even xtabond does not work. Doing this, Stata returns "no observations"
> (r(2000)).
> Unfortunately, I have no clue what could be wrong. I tried several options,
> including dropping several variables from the model. I saw that other users
> face similar problems. However, I could not find a viable solution.
> Any help would be greatly appreciated.
> Thanks!
> Julian Donaubauer
> Helmut Schmidt University
> Hamburg
> *
> *   For searches and help try:
> *
> *
> *


Muhammad Anees
Assistant Professor/Programme Coordinator
COMSATS Institute of Information Technology
Attock 43600, Pakistan

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index