Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: RE: bootstrap gives errors with -rd-

From   D-Ta <>
Subject   Re: st: RE: bootstrap gives errors with -rd-
Date   Sun, 13 Nov 2011 12:08:43 +0100

Yes, I use the latest version of -rd-. I also use the right syntax, i.e. bootstrap, reps(1999): rd outcome Z, n(50)

Am 13.11.2011 05:03, schrieb Austin Nichols:

The help file, refs, and prior posts make clear that the assignment
variable Z should always appear last in the variable list:

bootstrap, rep(200) : rd Y Z

Are you using the latest version?

ssc inst rd, replace

On Sat, Nov 12, 2011 at 12:43 PM, D-Ta<>  wrote:
sorry... -rd- stands for regression discontinuity and is a user written
command by Austin Nichols.


Am 11.11.2011 20:09, schrieb Nick Cox:

... and -rd- is ?



I have the following problem.

I use the -rd- command to estimate a local effect of  (a treatment) X on
outcomes Y (several ouotcomes, some binary and some continous) at Z=0 in
the following way:

bootstrap, rep(200) : rd Y X, n(50)

where X=1 if Z>=0 and X=0 if Z<0.

Z takes the values: -12 , -11.5, -11, .... ,-0.5, 0, 0.5, 1, ...,12
Around the cut-off value I have 15-20 observations in each category of Z.

When I run the command I get a lot of bootstrap replications that fail
(red X). This is more so for binary outcomes! I also tried to use
-bootstrap, strata(Z) rep(200)-  but the problem remains.

Can someone explain what I do wrong?

*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index