Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: reoprob claims to have no observations

From   Benjamin Volland <>
Subject   Re: st: reoprob claims to have no observations
Date   Tue, 25 Oct 2011 15:10:03 +0200

I guess, Nick was right, again. I just realized that I had not downloaded the update by Guillaume R. Frechette (May 2001, Stata Technical Bulletin, 61, p. 12:, which deals with unexpected abortions of maximization. With the update installed, the program runs like a charm. Hope this helps.

Best, Ben

On 05/09/2011 14:24, Nick Cox wrote:
-reoprob-'s code suggests that it ignores missings in a standard way,
and it is a wrapper for -oprobit- which would do that too. So,
although it's good that you got results, my hunch is that the
explanation lies elsewhere.


On Mon, Sep 5, 2011 at 1:06 PM, Benjamin Volland<>  wrote:
Dear statalisters,

just in case anyone runs into similar problems, I wanted to post that the
"solution" to the problem described below, was in the end fairly simple.
$indepvar contains the lagged dependent variable, which is (naturally)
missing for the first observation. Once I deleted the first observation for
each unit of analysis reoprob ran without a problem. Hence, my hunch is that
reoprob cannot deal with missing values. Hope this helps.

Best, Ben

On 30/08/2011 15:04, Benjamin Volland wrote:

Dear statalisters,

I'm currently trying to run a dynamic ordered probit random effects
panel estimation as suggested by Woolridge (2005, Journal of Applied
Econometrics, Vol. 20 (1), pp. 39-54).
I therefore make use of the reoprob command written by Guillaume
Frechette (2001, Stata Technical Bulletin, Vol. 10 (59), pp. 23-27).
I am using Stata version 10.1.
The panel is unbalanced (between 5 and 12 observations per unit of
observation). The dependent has 12 steps. The independents contain the
LDV, a number of controls (mostly dummies), plus the initial value of
the dependent and the mean values of all independents (as suggested by
Woolridge). I run a simple pooled ordered probit model up front to
identify all variables that may cause problems of multicollinearity
(e.g. the mean values of sex and race are the same as the actual values
of sex and race). These are dropped before the reoprob estimation, which
looks like this:

. reoprob foodc $indepvar $meanvarfood $ofoodvar firstfoodc, i(pid)

The program then (w/out any problem) runs through the constant-only model

. Fitting constant-only model:

. Iteration 0: log likelihood = -28629.788
. Iteration 1: log likelihood = -26312.933
. Iteration 2: log likelihood = -26271.232
. Iteration 3: log likelihood = -26269.137
. Iteration 4: log likelihood = -26269.133
. Iteration 5: log likelihood = -26269.133

but after the first iteration of the full model, stata tells me that
there are no observations

. Fitting full model:

. Iteration 0: log likelihood = -23495.781 (not concave)
. no observations
. r(2000);

Interestingly, when I specify the - trace - option it also performs
Iteration 1 before returning the same error code.
- xtreg ..., re - runs w/out problems (so does the user-written command
xtabond2 [Roodman]).
Does anyone have a suggestion how I could fix this?

Thanks so much, Ben
*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index