Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: Possible issue when stcompadj expands dataset

From   Christel Häggström <[email protected]>
To   "[email protected]" <[email protected]>
Subject   st: Possible issue when stcompadj expands dataset
Date   Fri, 26 Aug 2011 13:00:06 +0200

Dear statausers,

I have an issue with the command stcompadj. What I have understood, the command stcompadj expands the dataset (as described:; and my issue is that when I try to run the command I get error message.
I have tried the same command with a smaller dataset which works fine. I am currently using STATA 11 MP and have been able to run stcompet and stcrreg (takes 1-2 days to run) with the same dataset. The underlying timescale is age in years and I've tried with other covariates as well.
Copied output:

stset dat_exit_inc, fail(risk_inc==1) id(id) origin(dat_b) enter(dat_m_plus1y) scale(365.25)
   289871  total obs.
        5  ignored because id missing
     1200  obs. end on or before enter()
   288666  obs. remaining, representing
   288666  subjects
     7065  failures in single failure-per-subject data
  3390602  total analysis time at risk, at risk from t =         0
                             earliest observed entry t =  16.58316
                                  last observed exit t =   104.564

stcompadj smok=1, compet(2)
Multiple records per subjects not allowed.

Do I get this error message due to the size of the dataset? What is the maximum limit? Or is this due to something else?

Thanks for your consideration,
Christel Häggström,
PhD Student

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index