Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: RE: Problem with xi and xtivreg2

From   Juan Pablo Cote Baron <>
Subject   Re: st: RE: Problem with xi and xtivreg2
Date   Sun, 19 Jun 2011 13:43:11 -0500

Hi Mark,

Thanks for your response. I tried what you suggested but it didn't work. Having created the year dummies first, I typed:

xtivreg2 x w _Iyear_2004 _Iyear_2005 (y = z), fe robust

but I keep getting the same error message. I wonder what the problem could be.

Thanks again,


>----- Mensaje original -----
>2011/6/19 Schaffer, Mark E <>


>> -----Original Message-----
>> From:
>> [] On Behalf Of
>> Juan Pablo Cote Baron
>> Sent: 19 June 2011 00:40
>> To:
>> Subject: st: Problem with xi and xtivreg2
>> Dear statalist users,
>> I have a problem when using the xi: xtivreg2... combination.
>> I need to regress "x" on "w", an instrumented variable "y"
>> and on year dummies. I typed this:
>> xi: xtivreg2 x w i.year (y = z), fe robust
>> but it doesn't work. Instead, I get the error message "too
>> few variables specified r(102)", but I don't know what the
>> problem could be (the syntax works when I use it with another
>> cathegorical variable different from year) .

>What happens if you first use -xi- on its own to create the year
>dummies, and then use the year dummies in the estimation without -xi-?


>> Thanks in advance,
>> Juan Pablo Cote.

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index