Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at statalist.org.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: rollreg module


From   "a.carrozzone@libero.it" <a.carrozzone@libero.it>
To   statalist@hsphsun2.harvard.edu
Subject   st: rollreg module
Date   Sat, 5 Feb 2011 19:28:50 +0100 (CET)

Dear statalist,

I have a panel dataset and I am trying to use the rollreg module to run 
rolling regressions for each unit in the sample.

Unfortunately my sample has gaps in time for many units. The program requires 
that there are no gaps and I get an error message. If I fill the gaps by using 
the tsfill command (so by setting the gaps to be missing observations) the 
command still doesn't work.

Do you know if there is a way to run the rollreg command without dropping the 
units with gaps?

I also tried the rolling prefix to regress, but in this case the computation 
time is too long with a very large dataset.

Thanks a lot,


Andrea
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index