Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: error while doing IV

From   Rafal Raciborski <>
Subject   Re: st: error while doing IV
Date   Tue, 28 Sep 2010 10:23:05 -0500

Arka Roy Chaudhuri <> reports a problem with the -cluster()-
option in -ivregress-:

> I am having some problems in estimating a IV regression. It would be
> great if somebody could please help me with my problem.
> ivregress 2sls avggap (district_tariff_scaled
> =district_tariff_unscaled) time _Idistricti*
> [aweight=district_popn],cluster(districtid)
> (sum of wgt is   0.0000e+00)
> no observations
> r(2000);
> Surprisingly if I estimate the third equation without clustering over
> the districts Stata gives me results without any error. I tried using
> the vce option instead of the cluster option but I get the same error.

I suspect that 'districtid' is a string variable in which case -ivregress-
incorrectly marks out the estimation sample.  This behavior will be fixed
in the next Stata update.

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index