Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: AW: rename files - "! rename" doesn't work

From   "Martin Weiss" <>
To   <>
Subject   st: AW: rename files - "! rename" doesn't work
Date   Fri, 16 Apr 2010 16:44:53 +0200


-cd-ing beforehand help as well:

cd C:\
webuse auto, clear
save "myauto.dta", replace
dir *dta
!ren "myauto.dta"  "yourauto.dta"
dir *dta


-----Ursprüngliche Nachricht-----
[] Im Auftrag von Hewan Belay
Gesendet: Freitag, 16. April 2010 16:21
An: Stata List
Betreff: st: rename files - "! rename" doesn't work

Dear stata list,

Following Nick's guidelines in 
I tried to rename dta files from within stata but it didn't work. Here is
what I tried:

webuse auto
save "D:\myauto.dta", replace
! rename "D:\myauto.dta"  "D:\yourauto.dta"

All that happens is, a small window flashes in and then back out in a split
of a second. When I go to Windows explorer and look at the D/ folder, I
still find myauto there, not yourauto. I refreshed the windows explorer, and
also closed and opened it again, but it's still myauto. By way of
information, my operating system is Windows XP Professional, and I'm using
Stata 11. I tried the above also with -shell rename- instead of -! rename-,
but the same thing happens. What could be the problem?


*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index