Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: ivreg2 cannot produce first-stage result

From   Mo Phil <>
Subject   st: ivreg2 cannot produce first-stage result
Date   Tue, 6 Apr 2010 08:24:53 +0800

Dear All,

I used the following ivreg2 to estimate an IV-regression, but could
not produce the first-stage result.

.  ivreg2 my_y $xfirm $year_dummies choice_dummy (= choice_sic3),   first

Unable to display first-stage estimates; macro e(first) is missing

Unable to display summary of first-stage estimates; macro e(first) is missing

I browsed the Statalist, found a similiar posting, but the suggested
answer is that if OLS is used in the second stage, there is no
first-stage results.

But I actually used the same command syntax in another setting some
months ago, it worked.

I would appreciated any suggestions on how to obtain the first stage result.


> -----Original Message-----
> From:
> [] On Behalf Of
> Alemu Mekonnen
> Sent: Wednesday, December 12, 2007 1:47 AM
> To:
> Subject: st: A question about ivreg2
> Dear Statalisters,
> When I run ivreg2, I am not able to get the first-stage
> estimates even if I specify 'first' or 'ffirst' in the do
> file I am using (I do see OLS estimation for the second
> stage, though).

If you're using OLS in the second stage, then you have no endogenous
regressors.  This means there is no first stage, which explains why
ivreg2 does't report them.


*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index