Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: using varlist wildcards in anova

From   Phil Schumm <>
Subject   Re: st: using varlist wildcards in anova
Date   Sat, 3 Apr 2010 17:21:21 -0500

On Apr 3, 2010, at 4:45 PM, Vineet Bhagwat wrote:
So I guess I'm wondering why the command

"anova y t* " won't work, it gives the error "t ambiguous abbreviation"

I created a smaller test dataset with only 3 variables, y, t1991, and t1992 and get the same error, so I don't think it's stemming from the dataset but how anova works.

Hmm, that's strange -- if you have only y, t1991 and t1992 in your dataset, the command

    anova y t*

should definitely work. Of course, if you leave out the *, then you'll get what you described, i.e.,

    . anova y t
    t ambiguous abbreviation

You'll also get that if you have an errant space between the t and *:

    . anova y t *
    t ambiguous abbreviation

Are you typing the command interactively (i.e., in the command window), or are you executing it from a do-file? Regardless, this isn't due to -anova-, but rather is a function of how Stata is parsing the command line. For example, I presume that the command

    list y t*

will throw the same error for you?

If you want, take your dataset with 3 variables, type the commands

    keep in 1/3
    anova y t*

which, according to what you've described should throw an error, and then copy the commands and output from the Results window and paste them directly in an email message. One of us can then verify that we observe different behavior on our machine (i.e., that the command works); this will verify that you've got a problem with your Stata installation.

-- Phil

*   For searches and help try:

© Copyright 1996–2018 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index