Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: missing standard error because of stratum with single sampling unit


From   Michael Begg <mbstata@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   st: missing standard error because of stratum with single sampling unit
Date   Thu, 7 Jan 2010 18:33:56 +1100

Hi, 

I am working on a data from a 2 stage survey design with 2 stratum. When I calculate the mean of hhsize, the standard error is missing as shown below. 


svy: mean hhsize
(running mean on estimation sample)

Survey: Mean estimation

Number of strata =       2        Number of obs    =      5964
Number of PSUs   =     194        Population size  =  16041309
                                  Design df        =       192

--------------------------------------------------------------
             |             Linearized
             |       Mean   Std. Err.     [95% Conf. Interval]
-------------+------------------------------------------------
      hhsize |   4.656919          .             .           .
--------------------------------------------------------------
Note: missing standard error because of stratum with single
      sampling unit.


As per http://www.stata.com/support/faqs/stat/stratum.html, I check my data using svydes hhsize and find the following: 

Survey: Describing stage 1 sampling units

      pweight: weight
          VCE: linearized
  Single unit: missing
     Strata 1: rural
         SU 1: psu
        FPC 1: npsu
     Strata 2: <one>
         SU 2: ssu
        FPC 2: nssu
     Strata 3: <one>
         SU 3: hh
        FPC 3: nhh

                            				 #Obs with    #Obs with     #Obs per included Unit
           	#Units    	    #Units   	complete  	missing         ----------------------------
Stratum  included    omitted     	data      		data      		min       mean      max   
--------  	--------  	    --------  	--------  	      --------               --------  --------  --------
       1       136                0      		4241        	 0                      16      31.2        39
       2        58         	       0      		1723        	 0                      16      29.7        32
--------  	--------  	   --------  		--------  	     --------               --------  --------  --------
       2       194                0      		5964               0                       16      30.7        39
                              				   ------------------
                                       				5964

Why are the standard errors missing when both stratum have more than one sampling unit and there are no missing observations. 

Thanks for your help

Cheers

Michael 


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index