[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: RE: R: ANCOVA repeated measures error

From   "Lachenbruch, Peter" <[email protected]>
To   <[email protected]>
Subject   st: RE: R: ANCOVA repeated measures error
Date   Mon, 9 Nov 2009 12:50:53 -0800

Aren't these panel data?


Peter A. Lachenbruch
Department of Public Health
Oregon State University
Corvallis, OR 97330
Phone: 541-737-3832
FAX: 541-737-4001

-----Original Message-----
From: [email protected] [mailto:[email protected]] On Behalf Of Carlo Lazzaro
Sent: Monday, November 09, 2009 10:46 AM
To: [email protected]
Cc: 'Steve'
Subject: st: R: ANCOVA repeated measures error

Dear Steve,
would it be useful to invoke:

regress ser_conc drug age, robust cluster(id)


by drug, sort : regress ser_conc drug age, robust cluster(id)

Kind Regards,
-----Messaggio originale-----
Da: [email protected]
[mailto:[email protected]] Per conto di Steve
Inviato: lunedì 9 novembre 2009 18.49
A: [email protected]
Oggetto: st: ANCOVA repeated measures error

Hi all,

I recently moved to STATA from another statistical software and was
trying to analyze some data using ANCOVA, but I keep getting an error

The data being analyzed includes some serum concentration values for
an analyte (continuous variable) that was measured at multiple times
during a 3 year period from study participants.  The number of
measurements for each person ranges from 10-15.  The participants are
also divided into two groups (drug+ and drug-).  Over time, as the
person ages, the concentrations change.  We were trying to evaluate
whether the rate of change... the slope... was different between the
two groups.

To do this, I thought that I could do an ANCOVA which includes a
variable denoting repeated measures.  The syntax I used was:

anova ser_conc drug age, continuous(age) repeated(id) partial

where, id is a unique numeric id for each study subject.  The error I
get states: "could not determine between-subject basic unit; use
bseunit() option".  I've tried using the "bse" option but that doesn't
help.  I've also included id in the model but that didn't help either.
 Obviously, I'm doing something wrong with the syntax but haven't been
able to figure out the problem.

So what am I doing wrong there?  Is the model totally wrong the way I
have written it?  I tried searching for help on this but didn't get
far.  Would appreciate any help I can get.  Thanks a heap in advance.

- Steve
*   For searches and help try:

*   For searches and help try:

*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index