[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: mmerge - windows vs mac difference or something silly I am doing?

From   [email protected]
To   [email protected]
Subject   st: mmerge - windows vs mac difference or something silly I am doing?
Date   Wed, 16 Sep 2009 00:23:57 -0700 (PDT)

Hi. I have just been porting my do files from a windows machine (using jedit as the editor thanks Elliott!) to a Mac using textwrangler as an editor (thanks statamac). (Ok the adverts worked!) I have been busy changing all the path references (delightfully easy using textwrangler) but now have discovered that just one of my mmerge commands which ran fine on the windows system is producing an error with a particular data file. the error is "too many variables specified". It has done this in at least two do different do files. This is the command and response
. mmerge poan using "seifa2006range.dta" , type(n:1) unmatch(master)  //
The error message is
 too many variables specified

Now I have checked that the data set seifa2006range.dta is in the pathway (all my data files are in the same pathway cos they are all in the same folder). seifa2006range.dta only contains 30 variables  and about 2000 cases (it is linking postal codes to Australian census data) and I have oodles of memory available (2g) and this worked fine in the windows system.  But on the other hand I have used mmerge earlier on in the program bringing in other (and bigger) data sets and it worked fine under both mac and windows.  I am flummoxed  and cannot for the life of me think of how to deal with this. Any suggestions? It is rather a strange error message to get for this sort of command.  Thanks very much  Andrew.

Andrew J Brunskill,
University of Washington  [email protected]

*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index