[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: A problem with temporary file

From   Joseph McDonnell <>
Subject   st: A problem with temporary file
Date   Tue, 17 Feb 2009 11:48:32 +0930

Hi, all.

A colleague has a problem creating a temporary file. When I run the
following do file (on a shared network drive, not my own C: disk)...

. clear
. set obs 10
. gen n=_n
. list in 1/5
. tempfile one
. save `one', replace
. exit

it works perfectly well. A file is saved in "C:\Documents and
settings\MyName\Local settings\Temp". When she runs it in exactly the
same location, she gets the following error message

. invalid 'Settings'

. r(198);

immediately following the "save".

My first thought was that there was a write access problem. But our IT
guy checked and said there is no difference between my rights and
her's. He then installed Stata on his machine and had the same
problem!! But when he ran Stata on our server, it worked, no problem.

I'm at a bit of a loss as to why this happens. Has anyone encountered
this problem or have a suggestion as to where we look next? We're
using Stata 10 on XP.

Many thanks

*   For searches and help try:

© Copyright 1996–2023 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index