Statalist The Stata Listserver

[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Re: ram memory: microsoft fix does not work

From   "Michael Blasnik" <>
To   <>
Subject   st: Re: ram memory: microsoft fix does not work
Date   Mon, 06 Nov 2006 20:50:39 -0500

I have a few ideas which may (or may not) be helpful:

In my experience, 1.2GB-1.4GB is about all of the RAM you can expect to allocate to Stata when running 32-bit windows. If you need more memory allocated, you will probably need a new computer running a different OS. I'm not sure how much memory you can allocate to Stata with 32bit computers using Linux or Mac OS -- you may have to go to 64 bit.

You can try two things to try to get by with your current hardware -- making more memory available in Windows and reducing how much memory your dataset needs. You may be able to free up some memory by running as few processes as possible in Windows -- disabling all of the auto-start processes you can (check out running msconfig from Start->Run) and not launching any other software in the session. You should then look at your dataset and only keep the variables that you need for the estimation. Try to get rid of any long string variables and make sure that each variable that you do need is compressed as much as possible.

Good luck,

Michael Blasnik

----- Original Message ----- From: "Dr. Roberto Mura" <>
To: <>
Sent: Monday, November 06, 2006 6:46 PM
Subject: st: ram memory: microsoft fix does not work

Dear all,
the issue that I am experiencing is that, despite the 3,070 Mega of
Ram memory installed in my PC, the op.sys refuses to give me more
than 1.1Giga (set memory 1195m is the max it allows me).
This is a huge issue as I cannot run the xtabond2 estimations I need
to, since the system runs out of memory:
  xtabond2_mata():  3900  unable to allocate real <tmp>[35360,1049]
                  <istmt>:     -  function returned error

I have already checked the proposed solution in the web, namely:
and I already downloaded and installed the proposed Microsoft fix:
This did not produce any effect. I tried with Stata Technical Support
but they were unable to solve this issue.
I also tried to contact Microsoft directly but with little luck.
Please note that I am running Windows XP Home Edition Service Pack 2
(build 2600)  on a Compaq Presario SR1639UK with an AMD Athlon 64
Processor 3700. I am using Stata/SE 9.2 for Windows, Born 06 Oct 2006.
Please let me know if there is any more detail I can provide.
Any suggestion would be greatly appreciated.
*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index