Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Why won't -newey2- run?

From   Richard Williams <[email protected]>
To   [email protected]
Subject   Re: st: Why won't -newey2- run?
Date   Mon, 29 Mar 2004 22:45:19 -0500

At 04:15 AM 3/30/2004 +0100, Clive Nicholas wrote:

I'm currently having difficulties with using -newey2- in trying to fit an
OLS/Newey-West model comprising 102 sequentially-ordered by-elections.

. tsset id betime
       panel variable:  id, 1 to 3457
        time variable:  betime, 1 to 102

. newey2 becon clmargin [aw=region], lag(1) force

timevar (betime) may not contain missing values when option full is specified

I can't understand what I'm doing wrong here, and I certainly don't
understand what "option full" means here (it's not mentioned in -whelp
newey2-). There are neither any missing values in -tid- nor in the two
x-variables you see in the example. I've also tried running it without the
weight, without -force- and by entering -in 1/102- (having -sort-ed on
-tid-, of course), but exactly the same error returns every time.
I don't know much about this, but I can note that -newey2- includes the command
-tsfill, full-. Ergo, I suggest reading up on the -tsfill- command and figuring out if your data are violating any of its requirements.

Also, if you are not sure exactly where a program is dying, it can help to specify -set trace on- before running it.

Richard Williams, Notre Dame Dept of Sociology
OFFICE: (574)631-6668, (574)631-6463
FAX: (574)288-4373
HOME: (574)289-5227
EMAIL: [email protected]
WWW (personal):
WWW (department):

* For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index