Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Why won't -newey2- run?

From   "Clive Nicholas" <[email protected]>
To   [email protected]
Subject   st: Why won't -newey2- run?
Date   Tue, 30 Mar 2004 04:15:56 +0100 (BST)


I'm currently having difficulties with using -newey2- in trying to fit an
OLS/Newey-West model comprising 102 sequentially-ordered by-elections.

. tsset id betime
       panel variable:  id, 1 to 3457
        time variable:  betime, 1 to 102

. newey2 becon clmargin [aw=region], lag(1) force

timevar (betime) may not contain missing values when option full is specified

I can't understand what I'm doing wrong here, and I certainly don't
understand what "option full" means here (it's not mentioned in -whelp
newey2-). There are neither any missing values in -tid- nor in the two
x-variables you see in the example. I've also tried running it without the
weight, without -force- and by entering -in 1/102- (having -sort-ed on
-tid-, of course), but exactly the same error returns every time.

Statalisters will recall that last week, Justina Fischer posted a
reasonably similar difficulty with running -newey- (without wishing to
misrepresent her), to which -newey2- was given as the solution! I've also
tried running -newey- as well, but that hasn't worked either. The payoff
gained from unlocking the key to this, from a BLUE point of view, would be

CLIVE NICHOLAS        |t: 0(44)191 222 5969
Politics              |e: [email protected]
Newcastle University  |
*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index