Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Help -- Having Difficulty Updating STATA Under Mac OS X

From   Jeremy Fox <[email protected]>
To   [email protected]
Subject   st: Help -- Having Difficulty Updating STATA Under Mac OS X
Date   Sat, 3 May 2003 01:01:48 -0700

On Friday, May 2, 2003, at 11:33  PM, statalist-digest wrote:

I hope that someone from this list can help me.  This issue is really
starting to get old for me.  I have just tried to update my exe file
but the system will not do it -- I keep getting an error message.  The
usual drill is for me to erase the entire STATA file and to reinstall
the CD and then to do an update.  STATA Technical support has been of
little or no help on this issue.  I am currently running OS 10.2.5,
80GB harddisk, and 1.2 GB of memory.  What can I do to get a smooth
updating of the exe file?
I ran into this bug as well. In my case, there were two problems:
1. Stata downloaded a file with the wrong name (StataSE.1 in my case)
2. The file had the wrong permissions

My solution;
1. Delete the old Stata / StataSE (drag app to trash)
2. Open up Terminal
3. Type chmod u+rwx /Applications/Stata/StataSE
(there may be a non-UNIX geek method to do this using the "Get Info" command in the Finder and looking at the permissions tab. Basically, you want to give yourself permission to use the Stata application)
4. Rename StataSE.1 to StataSE

This was an annoying process caused by some bug in Stata or maybe putting the wrong file on StataCorp server, but there you go.


Jeremy T. Fox
[email protected]

* For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index