Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Re: Problem with generating component plus residual plot


From   Nick Cox <njcoxstata@gmail.com>
To   "statalist@hsphsun2.harvard.edu" <statalist@hsphsun2.harvard.edu>
Subject   Re: st: Re: Problem with generating component plus residual plot
Date   Tue, 23 Apr 2013 22:49:14 +0100

-regress- has the fullest array of post-estimation commands.

Strictly, -fit- is just a wrapper for -regress-, but -help fit- has
been discouraging for some versions now.

NB spelling is Stata, not STATA.


Nick
njcoxstata@gmail.com


On 23 April 2013 22:41, W R Goe <goe@k-state.edu> wrote:
> If fit is out-fo -date, what program would you recommend using in more recent versions of STATA to generate such diagnostics for multiple regression models?
>
> ----- Original Message -----
> From: "Nick Cox" <njcoxstata@gmail.com>
> To: statalist@hsphsun2.harvard.edu
> Sent: Tuesday, April 23, 2013 4:19:19 PM
> Subject: Re: st: Re: Problem with generating component plus residual plot
>
> You don't show any exact code or results here. You say you are using
> multivariate regression, which implies use of the Stata command
> -mvreg-. I'd guess rather that you are confusing multiple regression
> and multivariate regression.
>
> The -fit- command is versions out-of-date, but should still work.
>
> I take it that -cprplot- is issuing the error message, but on the
> information you give it is more likely to be that something is awry
> with your data.
>
> I think you need to show more precise details.
>
> As the FAQ says "Say exactly what you typed and exactly what Stata
> typed (or did) in response. N.B. exactly! If you can, reproduce the
> error with one of Stata's provided datasets or a simple concocted
> dataset that you include in your posting."
> Nick
> njcoxstata@gmail.com
>
>
> On 23 April 2013 21:59, W R Goe <goe@k-state.edu> wrote:
>> I am estimating a multivariate regression model using the STATA fit program. In examining evidence of departures from linearity, I am generating partial regression residual plots using the avplot subcommand and then component plus residual plots with the cprplot subcommand. I have encountered a problem where I am able to generate a partial regression residual plot for a particular independent variable using avplot, but am unable to generate the component plus plot for the same independent variable using cprplot and, I get an error message that reads: "error: value label S4 not found."
>>
>> Could someone kindly tell me what this error message means and how I might correct the problem?
>>
>> Thanks,
>>
>> Richard Goe
>>
>> Dept. of Sociology, Anthropology & Social Work
>> 204 Waters Hall
>> Kansas State University
>> Manhattan, KS 66506
>> Telephone:(785) 532-4973
>> Fax: (785) 532-6970
>> *
>> *   For searches and help try:
>> *   http://www.stata.com/help.cgi?search
>> *   http://www.stata.com/support/faqs/resources/statalist-faq/
>> *   http://www.ats.ucla.edu/stat/stata/
>
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/faqs/resources/statalist-faq/
> *   http://www.ats.ucla.edu/stat/stata/
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/faqs/resources/statalist-faq/
> *   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/faqs/resources/statalist-faq/
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index