Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Metareg syntax error for wsse option


From   Nick Cox <njcoxstata@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Metareg syntax error for wsse option
Date   Wed, 21 Nov 2012 00:04:51 +0000

I said earlier

"There is a typo in both help files in that -wsse()- is listed in the
syntax diagram as something that should be typed before the comma.
This is not biting Jon as he  appears to be using the option
correctly."

and this is the typo referred to.

Sorry, but I don't understand your latest post. If you installed
-metareg- correctly then installing or re-installing Stata should make
no difference to -metareg- as Stata's installation will never
overwrite -metareg-'s files. If you type -sysdir- then -metareg-
should be installed under PLUS, which (for example) is often
c:\ado\plus on a Windows computer. Also, differences within updates of
Stata 11 should not affect the operation of -metareg-.

The hypothesis that you are working (at least some of the time) with
an old -metareg- from 1998 is still unrefuted.

Nick

On Tue, Nov 20, 2012 at 11:38 PM, Jon Nelson <jpn@psu.edu> wrote:
> Sorry, it is not a typo on my part if that what's you are implying. But i think
> something in the original metareg command got corrupted by changes in Stata. I
> got out my original disk to Stata 11, and tried to use it to "repair" the
> program files. Somehow --don't ask me how -- i ended up with two versions of
> Stata 11 -- one labeled Stata-64_old (dated 09/01/11) and a second labeled
> Stata-64 (dated 02/16/12). The old Stata works with metareg and the new Stata
> does not.
>
> Signing off,
> Jon
>
> On Tue, Nov 20, 2012 03:13 PM Nick Cox <njcoxstata@gmail.com> wrote:
>>
>>That is what the syntax diagram says, but the code and examples contradict it.
>>
>>Hence my assertion that it's a typo.
>>
>>Nick
>>
>>On Tue, Nov 20, 2012 at 7:39 PM, Rebecca Pope <rebecca.a.pope@gmail.com> wrote:
>>> I think your command should be: metareg vsl09 loginc09 wsse(sd09), mm.
>>> Note, wsse() comes before the comma; this is why you are getting an
>>> error message about it not being an option.
>>>
>>> Here is the syntax from the help file for -metareg-:
>>>  metareg depvar [indepvars] [if] [in] wsse(varname) [, eform graph
>>>                randomsize noconstant mm reml eb knapphartung z tau2test
>>>                level(#) permute(# [, univariable detail joint(varlist1 [|
>>>                varlist2 ...])]) log maximize_options]
>>>
>>>
>>> Rebecca
>>>
>>>
>>>
>>>          __o                __o
>>>       _`\ <,_            _`\ <,_
>>>      (_)/   (_)          (_)/   (_)
>>> ========================>
>>>
>>> On Mon, Nov 19, 2012 at 1:24 PM, Nick Cox <njcoxstata@gmail.com> wrote:
>>>>
>>>> Jon Nelson replied to me privately. For several reasons why you are
>>>> asked not to do that, see
>>>>
>>>> http://www.stata.com/support/faqs/resources/statalist-faq/#private
>>>>
>>>> Most obviously, no one else can see your post. Also, replying to your
>>>> email does not constitute a promise of support until the problem is
>>>> solved!
>>>>
>>>> Programs don't suddenly stop working. There is some other explanation,
>>>> but I am sorry that I don't know what it is.
>>>>
>>>> The program can be downloaded from both SSC and SJ. The two versions
>>>> look identical. Nevertheless you should, as asked originally, explain
>>>> _where_ you got your copy from. (Jon should confirm that he is _not_
>>>> using the ancient version from STB-42.)
>>>>
>>>> There is a typo in both help files in that -wsse()- is listed in the
>>>> syntax diagram as something that should be typed before the comma.
>>>> This is not biting Jon as he  appears to be using the option
>>>> correctly. However, I have not used -metareg- in any of its
>>>> incarnations and can't advise further.
>>>>
>>>> If a better answer is not forthcoming, I would contact the program
>>>> author directly.
>>>>
>>>> Nick
>>>>
>>>> ---------- Forwarded message ----------
>>>> From: Jon Nelson <jpn@psu.edu>
>>>> Date: Mon, Nov 19, 2012 at 6:38 PM
>>>> Subject: Re: st: Metareg syntax error for wsse option
>>>> To: Nick Cox <njcoxstata@gmail.com>
>>>>
>>>>
>>>> Thanks, but removing spaces did not help. I still get the same error
> message.
>>>> Here is the exact version of a command:  metareg vsl09 loginc09, wsse(sd09)
> mm
>>>>
>>>> which worked 6 months ago and now returns the error message: "option wsse()
> not
>>>> allowed" r(198);
>>>>
>>>> Jon
>>>>
>>>> On Mon, Nov 19, 2012 12:53 PM Nick Cox <njcoxstata@gmail.com> wrote:
>>>> >
>>>> >-metareg- is from SJ and SSC. -metareg- in Stata terms is a command,
>>>> >not a macro.
>>>> >
>>>> >Exactly what you typed can only be guessed if you report that it was
>>>> >"something like" your example.
>>>> >
>>>> >It may be that you are putting a space in "wsse ()". If so, remove the
> space.
>>>> >
>>>> >Nick
>>>> >
>>>> >On Mon, Nov 19, 2012 at 4:54 PM, Jon Nelson <jpn@psu.edu> wrote:
>>>> >
>>>> >> I'm using the macro metareg to estimate random-effects regressions, using
>>>> data
>>>> >> that i used successfully six months ago. Now i'm getting an
>>>> >> error message "option wsse () not allowed" followed by r(198). This
> seems to
>>>> >> indicate a syntax error, but i can't see what i'm doing wrong or
>>>> >> determine other sources of error.
>>>> >>
>>>> >> My command line would be something like "metareg vsl09 logincome,
> wsse(sd09)
>>>> >> mm" , where sd09 is the variable for standard errors of the effect size
>>>> vsl09.
>>>> >> I tried using other data sets, and i get the same error. I tried
> reloading
>>>> the
>>>> >> macro. I checked the data for zeros or negative values. And wsse () is
>>>> >> a required option for metareg.
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/faqs/resources/statalist-faq/
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index