Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, is already up and running.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fwd: st: Metareg syntax error for wsse option

From   Nick Cox <>
Subject   Fwd: st: Metareg syntax error for wsse option
Date   Mon, 19 Nov 2012 19:24:18 +0000

Jon Nelson replied to me privately. For several reasons why you are
asked not to do that, see

Most obviously, no one else can see your post. Also, replying to your
email does not constitute a promise of support until the problem is

Programs don't suddenly stop working. There is some other explanation,
but I am sorry that I don't know what it is.

The program can be downloaded from both SSC and SJ. The two versions
look identical. Nevertheless you should, as asked originally, explain
_where_ you got your copy from. (Jon should confirm that he is _not_
using the ancient version from STB-42.)

There is a typo in both help files in that -wsse()- is listed in the
syntax diagram as something that should be typed before the comma.
This is not biting Jon as he  appears to be using the option
correctly. However, I have not used -metareg- in any of its
incarnations and can't advise further.

If a better answer is not forthcoming, I would contact the program
author directly.


---------- Forwarded message ----------
From: Jon Nelson <>
Date: Mon, Nov 19, 2012 at 6:38 PM
Subject: Re: st: Metareg syntax error for wsse option
To: Nick Cox <>

Thanks, but removing spaces did not help. I still get the same error message.
Here is the exact version of a command:  metareg vsl09 loginc09, wsse(sd09) mm

which worked 6 months ago and now returns the error message: "option wsse() not
allowed" r(198);


On Mon, Nov 19, 2012 12:53 PM Nick Cox <> wrote:
>-metareg- is from SJ and SSC. -metareg- in Stata terms is a command,
>not a macro.
>Exactly what you typed can only be guessed if you report that it was
>"something like" your example.
>It may be that you are putting a space in "wsse ()". If so, remove the space.
>On Mon, Nov 19, 2012 at 4:54 PM, Jon Nelson <> wrote:
>> I'm using the macro metareg to estimate random-effects regressions, using
>> that i used successfully six months ago. Now i'm getting an
>> error message "option wsse () not allowed" followed by r(198). This seems to
>> indicate a syntax error, but i can't see what i'm doing wrong or
>> determine other sources of error.
>> My command line would be something like "metareg vsl09 logincome, wsse(sd09)
>> mm" , where sd09 is the variable for standard errors of the effect size
>> I tried using other data sets, and i get the same error. I tried reloading
>> macro. I checked the data for zeros or negative values. And wsse () is
>> a required option for metareg.
*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index