Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, is already up and running.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Metareg syntax error for wsse option

From   Nick Cox <>
Subject   Re: st: Metareg syntax error for wsse option
Date   Mon, 19 Nov 2012 17:53:01 +0000

-metareg- is from SJ and SSC. -metareg- in Stata terms is a command,
not a macro.

Exactly what you typed can only be guessed if you report that it was
"something like" your example.

It may be that you are putting a space in "wsse ()". If so, remove the space.


On Mon, Nov 19, 2012 at 4:54 PM, Jon Nelson <> wrote:

> I'm using the macro metareg to estimate random-effects regressions, using data
> that i used successfully six months ago. Now i'm getting an
> error message "option wsse () not allowed" followed by r(198). This seems to
> indicate a syntax error, but i can't see what i'm doing wrong or
> determine other sources of error.
> My command line would be something like "metareg vsl09 logincome, wsse(sd09)
> mm" , where sd09 is the variable for standard errors of the effect size vsl09.
> I tried using other data sets, and i get the same error. I tried reloading the
> macro. I checked the data for zeros or negative values. And wsse () is
> a required option for metareg.
*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index