Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Stata 11.1 on Mac breaking user-written commands?


From   Ronan Conroy <rconroy@rcsi.ie>
To   "statalist@hsphsun2.harvard.edu" <statalist@hsphsun2.harvard.edu>
Subject   Re: st: Stata 11.1 on Mac breaking user-written commands?
Date   Wed, 9 Jun 2010 16:24:15 +0100

Curiouser and curiouser... Fortune ate two of my sausages at once!

1. I had installed the graph schemes from "A visual guide to Stata graphics" and was using one of them. Reverting to Stata's own schemes overcame the 'option plotregion1' error. All the schemes supplied with Stata work fine.

2. I was, on the same day, bitten by a feature of proprcspline, which is that the default label length is 20. One of my labels was 21 characters. Rewriting the command as

. proprcspline worry age, by(sex) lablength(all)

overcame this problem.

I might suggest to Maarten, however, that "all" seems like a sensible default, rather than 20.

Many thanks to everyone who tried and ran code!

r

On 9 Meith 2010, at 14:25, Maarten buis wrote:

Nick Cox's -stripplot- and Maarten Buis's -proprcspline-
have started to return errors on OS X

. proprcspline worry age, by(sex)
invalid label specifier, :  `"Not worrier"'  .
`"Sub-syndromal GAD"'  . `"GAD"':
r(198);

. proprcspline worry age
option plotregion1 not allowed
r(198);

I just tried both examples for -proprcspline- from
<http://www.maartenbuis.nl/software/proprcspline.html>
and I got no problem. I am using Widows XP though.
Since I can't reproduce the problem, I don't know what
I can do to solve the problem.




Ronan Conroy
=================================

rconroy@rcsi.ie
Royal College of Surgeons in Ireland
Epidemiology Department,
Beaux Lane House, Dublin 2, Ireland
+353 (0)1 402 2431
+353 (0)87 799 97 95
+353 (0)1 402 2764 (Fax - remember them?)
http://rcsi.academia.edu/RonanConroy

P    Before printing, think about the environment




*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index