Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Bug in graph matrix?


From   vwiggins@stata.com (Vince Wiggins, StataCorp)
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Bug in graph matrix?
Date   Thu, 22 Oct 2009 20:58:46 -0500

Fred Wolfe <fwolfe@arthritis-research.org> writes that -graph matrix- produces
color markers even when the graphics scheme is monochromatic,

> The following code has blue symbols (markers) despite selecting a
> mono scheme:
>
> graph matrix haq_ pain mood if eroundus <50 & ranuse,msize(tiny)
> jitter(8) title(EQ5D <50) scheme(bw) saving(figure5b, replace)
>
> The same "blue" results occurs when s2mono or s1mono is the scheme.

Not that it helps Fred, but the markers themselves are gray while their
outline is blue.  Fred's markers are so small that this distinction is
impossible to see.  

This is indeed a misfeature of the monochromatic schemes and we will fix it in
a future update.

This is rather obvious, but the interim workaround is to specify the color of
the markers, or at least the color of their outline.  Option -mcolor(gs6)-
will do the former and option -mlcolor(gs6)- will do the latter.  The results
are visually indistinguishable.


-- Vince 
   vwiggins@stata.com

 
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index