Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: bootstrap fails with qreg


From   "Feiveson, Alan H. (JSC-SK311)" <alan.h.feiveson@nasa.gov>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: bootstrap fails with qreg
Date   Wed, 3 Sep 2008 11:16:42 -0500

Hi - I tried to get bootstrapped standard errors with median regression
by using the -bs- command. The regression appears to run through all the
iterations, but at the end ,there seems to be a problem in collecting
all the estimates to get the bootstrapped standard error. I notice that
Bill Gould has provided code in STB-9 (sg11_1.ado) to do this, but this
is from some years ago and the -qreg- version that it uses might not be
the one we now have with Stata 10.1. So my questions are 
1) Is sg11-1.ado still the best way to do this ,other than bootstrapping
by hand with -bsample-? 
2) Is there a workaround using the current Stata 10.1 cabilities? 
3) Can this be done with cluster sampling? 
4) I'm curious - what is the reason for the failure (see below)?


AL Feiveson

. bs: qreg z4 zrs0
(running qreg on estimation sample)

Bootstrap replications (50)
----+--- 1 ---+--- 2 ---+--- 3 ---+--- 4 ---+--- 5 
..................................................    50

Median regression                                    Number of obs =
1860
  Raw sum of deviations 1217.215 (about -.99425226)
  Min sum of deviations 1217.215                     Pseudo R2     =
0.0000

last estimates not found
r(301);

. 

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index