Statalist The Stata Listserver

[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: Identifier dissapears?

From   "Scott Merryman" <>
To   <>
Subject   st: RE: Identifier dissapears?
Date   Fri, 25 Aug 2006 09:22:11 -0500

Take a look at -help tsset- and -help xt-.  You must have had the panel
variable declared at some point yesterday.  

The solution is to either follow the error message and add the i() (-xtreg
var1 var2, i(panelvar)-) or you -tsset- your data.

I do not understand your comments about the dialogue boxes, but if they did
not work you should take that up with tech support.


> -----Original Message-----
> From: [mailto:owner-
>] On Behalf Of Morten Hesse
> Sent: Friday, August 25, 2006 2:30 AM
> To:
> Subject: st: Identifier dissapears?
> Hi,
> I'm a new STATA user, so please apologize if this is a stupid question. I
> am
> analyzing panel data and yesterday (when I first tried), it worked fine,
> and
> I could use all the models. When I tried to run the model again it
> remembered my choice of identifier and time variable.
> Today, no matter what model I use, the identifier dissapears. That is,
> when
> I run the model, I get and error message called "i() required". I have
> tried
> to use the function "declare data set to be time-series data" and to press
> the panel settings button on the xtlogit dialogue box and the xtreg
> dialogue
> box.
> Has anybody got a solution?
> Greetings,
> Morten

*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index