Statalist The Stata Listserver

[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Ctrl-Insert: pet interface peeve (XP only)

From   Jeph Herrin <[email protected]>
To   [email protected]
Subject   st: Ctrl-Insert: pet interface peeve (XP only)
Date   Wed, 27 Sep 2006 13:28:18 -0400

This is mostly just a gripe, but perhaps there is also a (software)
solution out there.

I use Stata 9.2 on WinXp, all current. I have a 5-button mouse, which
means I can have two buttons assigned to Copy & Paste, respectively.
This works great in every application I run on Xp with the exception
of Stata.

In fact, the Paste button works perfectly, and will paste the buffer
into any Stata window that allows pasting. However the Copy button will
only copy from the Command window. Of course, what one most wants to
do is copy from the Results window, and several times a day (I'm a slow
study) I still select some results, click my Copy button, and get nothing.
As an added bonus, the contents I have selected are then inaccessible
via Ctrl-C - I have to deselect and re-select, then use Ctrl-C.

Of course, if Xp were a proper OS, I could assign Ctrl-C to the mouse
button, but the only options I have are "Copy". I suppose Xp assigns some
legacy code, such as Ctrl-Insert, and maybe all Stata programmers need
to do is redirect Ctrl-Insert => Ctrl-C. It seems that Ctrl-Insert, which
also typically works with Xp applications, does not work in the Results

This behavior began (I think) with Stata 9, or maybe 8. I know back in
7 the mouse worked fine, but those were also still Linux days so I may
be confusing the two transitions.

If on the other hand, there are users who have successfully mapped an
extra mouse key to Ctrl-C, maybe I just need a new mouse &/or driver.


*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index