Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: bootstrapping in stata 8

From   Chris Rohlfs <[email protected]>
To   [email protected]
Subject   st: bootstrapping in stata 8
Date   Fri, 31 Oct 2003 23:24:16 -0600 (CST)

hello everyone,

i'm having some problems getting a bootstrap program to work & would
appreciate anyone's comments.  i think the problem may be specific to
version 8.

anyways, i have a nonlinear estimation procedure nlcas, and i'm doing a
bootstrap to calculate standard errors for the mean marginal effect of the
variable x0.  my program looks like this:

program define nlmarg
	version 8.0

	if "`1'" == "?" {
		* the program output will be stored in the macro named t
		global S_1 "t"

* this calls the nonlinear program nlcas with dependent variable c

	quietly nl cas c

* nlcas.ado produces two global macros, $X0 and X0ART.  these two
* enter into my equation for the marginal effect variable `margfx'
* as below

	tempvar margfx
	gen `margfx' = $X0*c*(y0 + $X0ART*y0art)/(x0 + $X0ART*x0art)
	sum `margfx'

	local t = r(mean)

	post `1' (`t')


i run the program by typing this at the command line:

	bootstrap "nlmarg" t, reps(1000) dots noisily

the program shows the mean for `margfx' from the first run, but then gives
the error:

( invalid name

command -> nlmarg
error when command executed on original dataset under version 8 control

i think this means that `t' does not pass the information it's supposed to
be passing & instead simply returns nothing -- though i'm not quite sure
why.  i've tried writing it as $t as well & that doesn't seem to change
things.  any ideas of what could be the problem?

thank you very much,

*   For searches and help try:

© Copyright 1996–2024 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index