Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Windows update woes

From   Christopher Baum <>
Subject   st: Windows update woes
Date   Thu, 5 Jun 2003 07:07:26 -0400

Can someone out there who understands how Windows hides its filenames please help this chap? The preponderance of questions about 'why doesn't the ivendog routine work' come from Windows users who can't fiigure out how to update their executable (so have never done so)--three last week alone.


Begin forwarded message:

From: "P.Hua" <>
Date: Thu Jun 5, 2003 6:04:26 AM US/Eastern
To: Kit Baum <>
Subject: Re: ivendog

Dear Kit,

Many thanks for your help.
You are right. I am using Windows and did update all.
I tried to fellow the instructions, but I cannot find wstata.old, this after several times of update.
So, I just copy wstata.bin to paste on wstata.exe. The copy of wstata.bin apprears. But it doesnot work. When I did again update query, the version of installed stata executable is still on 15 dec, 2000, but the last available is 11 jun 2002. How can I do to have the last version of stata executable which has the update take effect?


At 15:46 04/06/03 -0400, vous avez écrit:

Dear Ping,

My guess is that you are (1) using Windows, (2) did 'update all' which downloaded the executable, and (3) did not follow the instructions regarding renaming .bin to .exe, etc. at the DOS level. This last step seems to be very difficult for many Windows users to deal with. If you do 'query born', you will probably find that your executable dates from 2001. If this is the case, ivendog (and a number of other things) will not work. You must update the version of the Stata executable that you are running to have the update take effect.


On Wednesday, Jun 4, 2003, at 15:24 US/Eastern, P.Hua wrote:

Dear Professor Baum,

Since many days, I tried to use ivendog to do endogeneity test. But I did not suceeded.
After update all, I installed the package st0030.
The title is SJ3-1-st0030, instrumental variables and GMM...
I can do all tests as before such as ivhettest, overid and ivreg2 except for ivendog (see attach file).
Where is the problem?
I am really seeking for your help
Many thanks,



Attachment: tryivendog.log
Description: Binary data

Kit Baum, Boston College Economics

© Copyright 1996–2019 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index