Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, is already up and running.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: Merging tables in outreg?

From   Sean Muller <>
To   "" <>
Subject   RE: st: Merging tables in outreg?
Date   Tue, 28 May 2013 09:30:12 +0000

Thanks Kit. You are right, my outreg package was out of date (I thought sg97_4 was the recent release but that is actually sg97_5). Having run the update I now get a *different* error earlier in the process.. (This also means that I don't know if the original error would recur because I don't get that far). The basic command sequence is:

xi: reg y f(X1 X2)
margins, dydx(X1 X2) at(X1=(1 2 3))
outreg, stats(b_dfdx se_dfdx)

I now get this error after the final command:

marginal estimates not found; see -help margins-

I did a search through the archive and found a thread on the same issue ("Re: st: Outreg margins error", 5 Sep 2012), which indicated that the problem should be resolved by either a new outreg update or by adding 'post' to the margins command:

margins, dydx(X1 X2) at(X1=(1 2 3)) post

But adding 'post' makes no difference in my case and my outreg package is now up to date.

One odd thing is that I ran the same code on a computer with Stata12 yesterday and it worked fine, both for compiling the tables and for merging them (the problem I had previously). The problem is that I most regularly have access to Stata11 so it would still be useful to figure-out what the problem is. My Stata 11 ado, executable and utilities are all up-to-date.

Anyone have any idea why this would work in Stata12 and not Stata11?



Sean M. Muller
School of Economics
University of Cape Town

From: [] on behalf of Christopher Baum []
Sent: 27 May 2013 09:46 AM
To: <>
Subject: Re: st: Merging tables in outreg?

On May 27, 2013, at 8:33 AM, Sean

> Any advice/assistance would be appreciated. (I'm using Stata11 by the way, in case this is relevant, and outreg package sg97_4).

Your mention of sg97_4 suggests you are using the SJ version of -outreg-, which is very old indeed. Any messages you may have read likely relate to a more recent version of John Luke Gallup's -outreg-, which is always on SSC. You should do

ssc install outreg, replace

to bring your -outreg- up to date, and then see whether that solves the problem.

Best wishes
Kit Baum

Kit Baum   |   Boston College Economics & DIW Berlin   |
                             An Introduction to Stata Programming  |
  An Introduction to Modern Econometrics Using Stata  |

*   For searches and help try:


This e-mail is subject to the UCT ICT policies and e-mail disclaimer published on our website at or obtainable from +27 21 650 9111. This e-mail is intended only for the person(s) to whom it is addressed. If the e-mail has reached you in error, please notify the author. If you are not the intended recipient of the e-mail you may not use, disclose, copy, redirect or print the content. If this e-mail is not related to the business of UCT it is sent by the sender in the sender's individual capacity.

*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index