Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: sqreg, extremely small coefficients, no standard error and t report


From   Chuanjian Bao <cbao@clemson.edu>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: sqreg, extremely small coefficients, no standard error and t report
Date   Thu, 23 Aug 2012 20:49:13 -0400

Hi Nick,

Thanks for your thought-provoking comments. The model is pretty
complicated, so I was unable to present here. I -qplot- the dependent
variable, and find that the line between q(.4) and q(.6) is level.
This might result in the awful results.

Since the quantile regression at the low, say, .25, and high, say,
.75, quantile is informative, may I just run on these value and report
accordingly?

Kind regards,

Vincent

On Thu, Aug 16, 2012 at 2:44 PM, Nick Cox <njcoxstata@gmail.com> wrote:
>
> You have problems on two levels.
>
> 1. Almost certainly, something about your data together with the model
> you are trying to fit means that -sqreg- can't perform as you hope.
> This often means that you are trying to fit a model that is too
> complicated or that something extreme about your data is causing
> -sqreg- to end up in some strange part of parameter space. For
> example, you may have one variable that is nearly constant except for
> a few values which act as outliers. This can easily happen with
> indicator variables (so-called dummy variables).
>
> 2. It's possible in principle that you have tickled a weird bug in
> -sqreg- but nothing in your posting helps us to see what is going on
> in any real detail.
>
> Please re-read the section of the FAQ that advises you to say
> _exactly_ what you typed in Stata and to give the _exact_ output. Word
> descriptions and paraphrases are cheap; syntax and output are
> valuable. The results of a -summarize- on the variables used in
> -sqreg- might help too.
>
> Nick
>
> On Thu, Aug 16, 2012 at 7:30 PM, Chuanjian Bao <cbao@clemson.edu> wrote:
>
> > I run a quantile regression using -sqreg-. With the results of q[25]
> > and q[75] being normal, that of q[50] is a little bit weird. All the
> > coefficients except the constant of q[50] equation are extremely
> > small, i.e., less than one billionth. And all the other columns of
> > q[50] equation are nothing but dots. The constant equals exactly to
> > the median of the dependent variable of the sample.
> >
> > In addition, I run a qreg, whose default quantile value is the median.
> > The coefficients and the standard error are both extremely small. And
> > the constant equals to the median of the dependent variable.
> >
> > Any suggestions on what the problem is will be highly appreciated.
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index