Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: xtivreg2 invalid variable name r(198); while using first or fe option


From   "Daniel Schalling" <daniel.schalling@uni-weimar.de>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: xtivreg2 invalid variable name r(198); while using first or fe option
Date   Wed, 5 Oct 2011 12:32:40 +0200

Hi Statalist,

I used xtivreg2 with different simple syntaxes and got, when using specific
options, the error message " invalid name r(198);":
- xtivreg2 depvar [varlist1] (endogvar=iv),fe   --> one variable of varlist1
is said to have an " invalid name r(198);"
- xtivreg2 depvar [varlist1] (endogvar=iv),fe first  --> the same variable
of varlist1 is said to have an " invalid name r(198);"
- xtivreg2 depvar [varlist1] (endogvar=iv),fd   --> estimation works
- xtivreg2 depvar [varlist1] (endogvar=iv),fd first --> depvar is said to
have an " invalid name r(198);"

When I'm trying for example
- xtivreg depvar [varlist1] (endogvar=iv),fe first
the estimation works.

What is the problem for that and how can it be solved?

I found this topic about that problem:
http://statalist.1588530.n2.nabble.com/st-Problem-with-xtivreg2-td4180979.ht
ml

But I'm not sure about how to implement the suggested solution.

Thanks a lot, Daniel.

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index