Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: ml maximize works if ml check is run first but hits a discontinuous region otherwise Poi TSP


From   Alex Olssen <alex.olssen@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   st: ml maximize works if ml check is run first but hits a discontinuous region otherwise Poi TSP
Date   Fri, 6 May 2011 15:58:38 +1200

Dear Statlisters,

I am in the process of reproducing the results from Berndt and Savin's
1975 Econometrica estimation of a singular system of equations with
autoregressive errors in Stata using manual maximum likelihood.

Poi's stata help desk articles have been of invaluable assistance.

I have noticed something odd.

For my estimation of model 7 in table 1

If I run the sequence

ml model d0 ...
ml check
ml maximize

everything runs fine and the results are similar to those in Berndt and Savin.

If I run the sequence

ml model d0 ...
ml maximize

Stata hits a discontinuous region.

Any ideas what is going on here?

Also, for model 8, my maximum likelihood procedure in Stata reproduces
Berndt and Savin's coefficients to only 2 decimal places - at the 3rd
decimal place there are often differences.
Standard errors are reproduced more accurately.

Does anyone have any ideas what is happening here either?  I have seen
somebody reproduce one part of Berndt and Savin in TSP and their
results were much closer - the paper was originally done in TSP.

Kind regards,

Alex
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index