Bookmark and Share

Notice: On April 23, 2014, Statalist moved from an email list to a forum, based at

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: file name problem with stata2mplus

From   Anders Alexandersson <>
Subject   Re: st: file name problem with stata2mplus
Date   Mon, 20 Dec 2010 10:29:06 -0500

Evelyn, I can reproduce the problem using Stata/SE 11.1 for Windows (32 bit).

The -stata2mplus- command is a user-written program by Michael
Mitchell. You may also want to consider the user-written command

There appears to be a small problem in -stata2mplus- on line 40 which,
I think, should read:
outsheet using "`using'.dat" , comma nonames nolabel `replace'

Your workaround was good because it was simple and it worked. You
should be able to rename directories (folders) and files without
having to use a USB stick.
Another workaround is to fix the code on line 40. If you do this, then
I suggest you also rename the program on lines 7 and 8 to something
else, for example to -stata2mplus2-, and add a comment at the top. You
would then use the modified program.

Anders Alexandersson

On Mon, Dec 20, 2010, Evelyn Ersanilli <> wrote:
> I've been experiencing some problems with converting a file from Stata to Mplus using the 'stata2mplus' command
> The problem is that the command does not seem to accept spaces in the destination file/folder name.
> The normal Stata strategy of using quotation marks doesn't seem to work
> I've tried:
> stata2mplus using  "C:\My Documents\Pilot 2" , replace
> invalid 'Documents'
> r(198);
> [...]
> I've found a work-around by putting the file on a USB stick so that I can lose the 'My Documents' part, but I feel that there must be a better way.
> Any suggestions?

*   For searches and help try:

© Copyright 1996–2017 StataCorp LLC   |   Terms of use   |   Privacy   |   Contact us   |   Site index